Temporary failure in name resolution


#1

I’ve set up mosquito.conf on my RPi3b exactly as documented. Then restarted mosquitto and examined the mosquitto.log:

Connecting bridge kappelt-gbridge (mqtt.gbridge.io:8883)

Error creating bridge:Temporary failure in name resolution.

Unable to connect to bridge…

I’m sure that gbridge is not the problem. But being new to linux, I have no idea where to start looking for a solution. Any help would be appreciated.


#2

are you sure your pi has an internet connection? From command line can you ping gbridge.io and google.com?


#3

Ping worked just fine. Tried replacing address mqtt.gbridge.io:8883 with 88.99.85.248:8883 in mosquitto.conf to avoid DNS. But then got “network is unreachable “ message.


#4

sudo ufw allow out 53,113,123/udp

Can you try that
Run it from the command line


#5

sudo ufw allow out 53,113,123/udp returned:

WARN: /lib is world writable!
WARN: /etc is world writable!
WARN: /usr is world writable!
Rules updated
Rules updated (v6)

I have no idea what this means. :slight_smile: But I’m guessing that my firewall is not to blame.


#6

I think that my router was automatically changing from 2.4 to 5.0 GHz. When I disabled 5.0 GHz, mosquitto connected to mqtt.gbridge.io. I still get the “Temporary failure on name resolution “ message. But it now indeed temporary and I’m able to connect.

Thanks for your help.