Help: MQTT Bridge


#1

I am trying to setup a bridge in Home Assistant using the Mosquitto broker.
I have created a config file and it is being read

connection kappelt-gbridge
address mqtt.gbridge.io:8883
bridge_attempt_unsubscribe true
bridge_protocol_version mqttv31
cleansession true
remote_username gbridge-u795
remote_password MqttPasswordGoesHERE
remote_clientid gbridge-u795-as99df
bridge_capath /etc/ssl/certs/
bridge_tls_version tlsv1.2

topic gBridge/u795/+/+ both 0 "" ""
topic gBridge/u795/+/+/set both 0 "" ""
topic cmnd/# in 0 Basement2/ gBridge/u7/
topic stat/# out 0 Basement2/ gBridge/u7/

I can see the config file being read and my other devices connecting.

[INFO] No local user available 
[INFO] Initialize Hass.io Add-on services 
[INFO] Initialize Home Assistant discovery 
[INFO] Start Mosquitto daemon 
1551625451: mosquitto version 1.4.15 (build date 2018-03-04 15:14:46+0000) starting 
1551625451: Config loaded from /etc/mosquitto.conf. 
1551625451: *** auth-plug: startup 
1551625451: ** Configured order: http 
1551625451: Opening ipv4 listen socket on port 1883. 
1551625451: Opening ipv6 listen socket on port 1883. 
1551625451: Opening websockets listen socket on port 1884. 
1551625451: Opening ipv4 listen socket on port 8883. 
1551625451: Opening ipv6 listen socket on port 8883. 
1551625451: Opening websockets listen socket on port 8884. 
1551625451: Warning: Mosquitto should not be run as root/administrator. 
1551625451: Connecting bridge kappelt-gbridge (mqtt.gbridge.io:8883) 
1551625451: New connection from 192.168.1.137 on port 1883. 
[INFO] found mqttuser1 on Home Assistant 
1551625451: New client connected from 192.168.1.137 as MQTTGarageDoor_324fed7bd580 (c1, k60, u'mqttuser1'). 
1551625452: New connection from 172.30.32.1 on port 1883. 
1551625453: Socket error on client <unknown>, disconnecting. 
1551625453: New connection from 172.30.32.1 on port 1883. 
[INFO] found homeassistant on local database 
1551625453: New client connected from 172.30.32.1 as 95edf3a7-5a27-4093-9256-45c4c4027b7d (c1, k60, u'homeassistant'). 
1551625460: New connection from 192.168.1.121 on port 1883. 
[INFO] found mqttuser1 on Home Assistant 
1551625461: New client connected from 192.168.1.121 as DVES_EF64C3 (c1, k10, u'mqttuser1').

I just don’t see it connecting to the gBridge device.
Oh and I have a light switch setup with Tasmota that I am trying to connect.
What other info do you need to help me get this working?