Didn't get response


#1

Hi all!
I try to set up gBridge with ESP8266 for open door;
When I told: “Hey google, open the door” - door is opened, but Google Assistant answered: “Sorry, I didn’t get any response”. What I do wrong?


#2

Have you tried 2-factor authentication?
For doors, locks, etc 2FA is expected by google I think.


#3

Have you tried sending some data (anything but 0) to the status topic? Sometimes, Google expects to have some state information in cache before allowing commands


#4

Yes, I use 2FA for Google.


#5

Yes, when I got command from MQTT broker, I immediately response: client.publish(MQTT_TOPIC_STATE, STATE_ON);
MQTT_TOPIC_STATE: gBridge/u***/d****/openclose/set
STATE_ON: 100
Problem only in Google Assistant on phone. Google Home opens door and is silent.


#6

What language of Google Assistant are you using? It might depend on that fact, I’ve tried (and verified) that feature using German and English.

Definitly, this is unfortunately not a problem with gBridge. gBridge doesn’t differ inbetween Google Home or Google Assistant (and is even unable to do so, since they use the same API and interface for integration). Propably, this is a problem with the door device not yet being supported officially by Google. I think, there is nothing you can do but waiting for it to be published finally (apart from clearing all your device caches and ensuring you are using the most current version of all Google apps)


#7

I use Russian language. And you are right! I changed language on English in the phone ( Google Home don’t support Russian yet, and using by default English) and it worked well.
Thanks for your help!!