A little help to make this work please


#1

Hi all,

Ok, i want to make my google home mini work with my raspberry domoticz but not getting it.
What I did.

register account
add device
connect google assistant.
So far so good.

I’m in the section “Test it” Everything is ready now! Messages will now be available on gBridge’s public MQTT server. You can connect to it:

Question: How do I connect to it
I’m not so known to programming. I can make a connection with putty to my rasp, then what?
I enter the example ( with my own gbridge id)
mosquitto_sub --username your-mqtt-username
–pw your-mqtt-password
–capath /etc/ssl/certs/
–host mqtt.gbridge.io
–port 8883
–topic gBridge/xx/xx/onoff

But nothing is happing, what do i do wrong?


#2

Have you installed Mosquitto client on the PI


#3

Yes, i’m using some zigbee lightbulbs with the mqtt broker and mosqyitto ( usb stick in my raspberry)


#4

Anyone? it’s an awesome project and really want to control my lights with google home.
I have a mosquitto client on my raspberry to control my zigbee lights. Do i have to install an other client for the jbridge?


#5

I will try to help you if I can…

when you say nothing is happening… have you got MQTT Exporer installed? If so, connect that to your MQQT Set up and whats going on.

I dont have the same set up as you but I have similar. I have gBridge connecting to an MQTT Client on Homey and and MQTT Hub that brokers the info…

I was having problems until I matched the topics up correctly.

I had to use MQTT Explorer to see what Homey sent out when an action occurred…
Then reconfigure the action topic in gBridge to match…

Insterestingly, for me, it required renaming the topic device name and moving /set to the action topic not the status topic


#6

I don’t have a mqtt explorer on my raspberry but I can view the logs with this command
sudo journalctl -u zigbee2mqtt.service -f
There I can see all the activitiy. If i turn on my zigbee light it shows there. I think that is what you mean?
When i give the command “oke google turn on my lights in de livingroom” Google give me the answer/ “oke i will turn youre lights on in the livingroom” But nothinh happens. My log is not showing anything so it doenst go into my domticz system.

Edit: I put a second mqtt client in my domoticz system but still not working. Did nog know if i have to put a second mqtt client in there, just tried it to be sure


#7

The log in domoticz is telling me this:
2019-02-26 15:33:38.697 Status: MQTT: Connecting to mqtt.gbridge.io:8883

2019-02-26 15:33:38.697 Status: MQTT: enabled TLS mode

2019-02-26 15:33:38.713 Error: MQTT: Failed to start, return code: 8 (Check IP/Port)


#8

ok… need better logs on this one then…

can you check if your MQQT set up uses LWT (Last Will and Testament)? If so, that must be disabled


#9

I’m sorry konrad wlash but i’m not a programmer so i dont dont how to do that.
Do you know the comand for that?

Was my last idea in the good direction that i need a second mqtt client in my domoticz?
My other mqtt client for the lightblups is working just fine


#10

no… I think one client is fine…

In your MQTT Client settings you will enable or disable LWT and it needs to be disabled

If you are getting Error: MQTT: Failed to start, return code: 8 (Check IP/Port) there is a network issue that must be resolved first.

From the RPI command line - Ping gbridge.io
Do you get a reply?


#11

The mqqt failed to start error was because I got 2 mqtt clients i gues. I turned the onther one of and the error is gone.
Yes i get a response if i ping brigdhe.io so no problem there.
What i dont get is how my google home is connecting to my raspberry with domiticz. there must me a connection to get the command from google home to rasp.
Do i have to change the mosquitto conf file?


#12

What i dont get is how my google home is connecting to my raspberry with domiticz. there must me a connection to get the command from google home to rasp.

Yes… thats what gBridge is doing for you… you create a device in gBridge that matches the ACTION and STATUS Topics in your mosquitto install and then

Google Home > gBridge > Local Mosquitto > Device


#13

it may help to see visually how it works for me - In fact, that whole thread covers much of what you are asking in the first 20 posts
I wrote a guide on connecting Homey to gBridge

Substitute Homey for Local Mosquitto install and it should be the same

@peter will need to chime in here and clarify if anything else is needed…


#14

Oke i understand now, So i don’t have to change anything on my raspberry/domitcz.
I manage to connect to the jbridge and it shows me my light I connected to the system.
When i ask google to turn on my light it say it will but nothinh is happening so somewhere it’s not connected.
I appreciate youre help…
I am going to read youre guide. There is only one difference . you are using homey and i am using domiticz. and using Zigbee2mqtt - open source zigbee bridge usb stick


#15

@wouter Please append the parameters -d -v to your mosquitto_sub command, we will se some more information about the connection then there. Currently, we are only digging in the dark…

Best regards,
Peter